guest.

Utilisateur(s) parcourant ce sujet : 1 visiteur(s)

Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
2080 5
MàJ béta 6 vers 7
#1
Salut SelMaK,

J'ai essayé de mettre à jour l'application sur la nouvelle version beta 7, cependant je galère un peu Sad
Pour rappel j'ai installé l'application sur une VM Windows avec WampServer, j'utilise mysql et php7.4.9

J' ai suivi ta procédure pour mettre à jours les fichiers, cependant je constat que j'ai pas de fichier phinx.yml
J'ai tenté d'installer composer, créé le fichier composer.json, puis mis à jours les dépendances.

Après ca je ne parvenais toujours pas à mettre à jours comme tu l'explique, j'ai tenté de remplacer les fichiers de la version beta 6 avec la 7 en excluant le fichier .env et le dossier vendor. A ce moment là, quand je vais sur la page admin, j'ai une erreur php > "private Session $session;" ligne 14 > "...src\Auth\Auth.php"

A moins que je ne comprenne pas la démarche à suivre ou que je me trompe de manip si non je réinstalle de zéro l'application, avez-vous une solution à me proposer ?
#2
Tu as téléchargé quelle version Proaxive (il faut la Net-Install pour composer) ?
Je ne fais pas de support par MP/Courriel
Nouvelle question => Nouveau sujet
#3
(30-03-2021, 02:30 PM)SelMaK a écrit : Tu as téléchargé quelle version Proaxive (il faut la Net-Install pour composer) ?

J'ai pris la dernière version disponible, et oui c'est vrais j'ai pas pris le net-install quand j'y pense... oups Sad

Du coup, j'ai juste remplacer les fichiers de la beta 6 par la beta 7 sans le fichier env. pour garder la config. et réimporter la BDD de la beta 7 et ca fonctionne normalement Wink .
Pour la BDD j'avais créé des tests (clients, équipement,inter...) du coup j'ai dû les recréer, est-ce qu'il a une manip pour garder ces enregistrements ?
#4
Vu ton message, je suppose que tu sais te servir de composer, je te conseil de privilégier cette version Wink

- Mise à jour des packages
- Gestion de base données beaucoup plus simple (plus de vidage de base de données suivant les versions bêta)
- Moins de souci de droit d'accès de l'application aux packages

Concernant la base de données pour la version Full de Proaxive, la table pour les débours a été ajoutée. Après si il y a d'autre composant à ajouter, il y a risque de vidage de table (d'où la Net-Install, via les migrations)

Proaxive Net-Install est vraiment la base du projet.
Je ne fais pas de support par MP/Courriel
Nouvelle question => Nouveau sujet
#5
(30-03-2021, 02:54 PM)SelMaK a écrit : Vu ton message, je suppose que tu sais te servir de composer, je te conseil de privilégier cette version Wink

- Mise à jour des packages
- Gestion de base données beaucoup plus simple (plus de vidage de base de données suivant les versions bêta)
- Moins de souci de droit d'accès de l'application aux packages

Concernant la base de données pour la version Full de Proaxive, la table pour les débours a été ajoutée. Après si il y a d'autre composant à ajouter, il y a risque de vidage de table (d'où la Net-Install, via les migrations)

Proaxive Net-Install est vraiment la base du projet.

Je te remercie pour ces précisions, cependant j'apprend à utiliser les outils que tu mentionne, ceci dis je ne sais pas plus que ca utiliser "composer".
Avec l'environnement local que j'ai créé sous Windows avec WampServer, j'observe et j'apprend le fonctionnement. Peut-être que je devais l'essayer un environnement linux :/
#6
Composer est aussi disponible sous Windows Smile

https://getcomposer.org/doc/00-intro.md#...on-windows
Je ne fais pas de support par MP/Courriel
Nouvelle question => Nouveau sujet


Atteindre :